Archive

Archive for August, 2012

EIGRP

August 14, 2012 Leave a comment

Distance vector protocol, but Cisco prefers “hybrid. Distance vector prevention mechanisms may be in place (e.g. split horizon).

classless protocol finds best path through network using bandwidth and delay. Delay is a static configuration under “router conf mode”. Adjusting weights, not recommended:
metric weights K1 K2 K3 K4 K5
0 1 (bw) 0 (load) 1 (delay) 0 (reliability) 0 (mtu)

EIGRP dual algorithm (SPF) is the only routing algorithm that keeps a feasible successor route. Successor (Primary), Feasible Successor (B)

Cisco proprietary.

R1
conf t
router eigrp 500
no auto-summary
network 170.100.0.0

R4
sh ip int br
sh ip protocols
conf t
access-list 3 deny 155.155.3.0 0.0.0.255
access-list 3 permit any
route-map rip-2-eigrp
match ip address 3
router eigrp 500
redistribute rip metric 1500 0 255 1 1500 route-map rip-2-eigrp

R1
sh ip route

Advertisements
Categories: Cisco, Routing

ISDN

August 5, 2012 Leave a comment

BRI (128k) / PRI (T1) – B-channels (64k), D-channels (16k on BRI, 64k on PRI), D channels always on

Encapsulations
B-channels (HDLC or PPP) (HDLC has no multilink, so PPP preferred)
D-channels (Q.921 – layer 2 signaling between ISDN router and SP Q.931 layer 3 – end to end signaling)

Basic ISDN config requirements (2 things):
1. ISDN switch-type (global & if)
2. Service Profile ID (SPIDs)- tracks time on ISDN

Dial on Demand Routing (5 steps)
1. configure switch-type and SPIDs
2. specify interesting traffic (what traffic is passed)
3. configure dialer information (phone numbers)
4. configure optional parameters
5. configure traffic routing over ISDN

Big verification commands:
show isdn status
show dialer
debug dialer

R5
conf t
int bri0
ip address 172.20.1.2 255.255.255.252
isdn switch-type basic-5ess
isdn spid1 111
exit
dialer-list 1 protocol ip permit
int bri0
dialer-group 1
encapsulation ppp
ppp multilink
dialer load-threshold 1 either <– when to initiate another call on another channel based on bw usage 1-255 (1-100%)
dialer map ip 172.20.1.1 broadcast 4802222222
no shutdown

R6
conf t
int bri 0
ip address 172.20.1.1 255.255.255.252
isdn switch-type basic-5ess
isdn spid1 222
dialer-list 1 protocol ip permit
int bri 0
dialer-group 1
encapsulation ppp
ppp multilink
dialer load-threshold 1 either (threshold decision based on max inbound/outbound traffic…only have to do on one side)
dialer map ip 172.20.1.2 broadcast 4801111111
no shutdown

show ip int bri
BRI0 <– D-channel
BRI0:1 <– B-channel
BRI0:2 <– B-channel

show isdn status (shows all L1-L3 layers)
TEI (SP address mapped to)

show dialer (shows the B channels and phone number mappings)

# ISDN lines won't disconnect w/o specifying following command
int bri 0
dialer idle-timeout 30 (30s)

Floating static routes (check return routes work too)
R6
conf t
ip route 192.168.2.0 255.255.255.0 172.20.1.2 250 (admin distance of 250)
ip route 172.16.0.0 255.255.0.0 172.20.1.2 250

# Not real world like since it will keep links up, but necessary for CCIE labs
Activating dynamic routing over ISDN
R6
conf t
router ospf 1
network 172.20.1.1 0.0.0.0 area 0
conf t
int s0
backup interface bri 0 (make bri 0 backup to s0)
backup delay 3 15 (bring up backup bri0 in 3 seconds if s0 fails and drop bri0 in 15s if s0 is active)

To test, can't shutdown interface s0
R6
int s0
encap hdlc (to fail the line, ppp was set)
show ip route

3rd method:
R6
conf t
router ospf 1
network 172.20.1.1 0.0.0.0 area 0

R5
conf t
router ospf 1
network 172.20.1.2 0.0.0.0 area 0
show ip ospf neighbor
# there should be 2 neighbor IDs, from bri0, s1.1
conf t
int bri 0
ip ospf demand-circuit <– suppresses hello msgs, minimizing traffic and only sending updates

R6
conf t
int bri 0
ip ospf demand-circuit
sh ip int brief
#shows BRI0 up, but BRI0:1, BRI0:2 down
sh ip ospf neighbor
#will show dead time as "-" because hellos are suppressed, neighbor still shows even though links are down

#If there are external routes being propagated through ASBR (AS boundary router), it will keep the ISDN links up

#How to filter, change the ISDN interfaces into its own A2 stub or totally stubby area

R6 (dialer watchlist, watches specific network to disappear and uses it as last resort for routing)
show ip route
conf t
dialer watch-list 10 ip 172.16.4.0 255.255.255.0 <– network have to match exactly
dialer watch-list 10 ip 172.16.5.0 255.255.255.0
int bri 0
dialer watch-group 10
dialer map ip 172.16.4.0 4801111111 <– what number to dial in case this network goes down
dialer map ip 172.16.5.0 4801111111

#testing dialer map
R6
conf t
int s0
shut
# will see s0 down, bri0:1, bri0:2 up and connect to R5

Categories: Cisco, Routing

Syslog output to remote host

August 1, 2012 Leave a comment

Syslog will output to UDP port 514 on a remote host.

Configuring syslog to remote hosts on the local sending host:
For RHEL/OEL Linux:
Edit /etc/syslog.conf
Append the desired messages to receive to remote host:
*.* @
#service syslogd restart

On HP-UX:
Edit /etc/syslog.conf
Choose the level of logging desired.
Append to file.
*.emerg;*.alert;*.crit;*.err;*.warning;*.notice;*.info;*.debug @
#/sbin/init.d/syslogd stop
#/sbin/init.d/syslogd start

Test by generating a syslog message:
#logger “Test alert from “

Categories: HP-UX, Linux, Redhat