Internal Routing Protocols RIP, EIGRP

RIP
defined in RFC 1058, redefined in version 2 RFC 1721, 1722, 1723
RIPv2
-MD5 authentication
-external route tages
-multicast route updates
-VLSM support (classless)

R1
conf t
router rip
network 170.100.0.0
show ip protocols (see version 1,2)
router rip
version 2
show ip protocols (only send/rcv v2)
int e1/0
ip rip send version 1 2
router rip
passive-interface s0/0.2 <– suppresses hello pkts from in/out, stops neighbor adjacency
passive-interface e1/0
router eigrp 2000
passive-interface s0/0.1
passive-interface s0/0.2
exit
router eigrp 2000
redistribute rip metric 1500 0 255 1 1500
router rip
redistribute eigrp 2000
redistribute eigrp 2000 metric 2

# Using directed unicast to neighbor on RIPv2
R1
conf t
router rip
# defining neighbor will only send unicast for RIPv2
neighbor x.x.x.x

# Route filtering option, offset-list, if you can't use filters
offset-list 1 in 14 <– adds 14 metric to routes, if you want to filter it out, 15 hops and it is declared dropped

# set timers
timers basic 60 180 240 360 <– if you want to increase bw efficiency, but increases convergence time as well

# Forcing a router to use EIGRP external broadcast routes injected by defining specific networks
R1
conf t
router eigrp 2000
no network 170.100.0.0
network 170.100.10.0 0.0.0.255
network 170.100.200.0 0.0.0.255

# Using distribute lists to filter routes
R1
conf t
access-list 50 deny 170.100.10.0 0.0.0.255
access-list 50 permit any
router rip
distribute-list 50 out s0/0.1

debug ip rip

  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: